How to resolve admin page opening issue after tomcat configuration in eclipse

Issue:

So often you would have noticed after tomcat configuration in eclipse, the admin start page never opens!

Reason:

Eclipse doesn’t copy the default application folders (e.g. ROOT) when it creates the tomcat specific folder inside the workspace.

Solution:

  1. Go to your “eclipse-workspace -> .metadata -> .plugins -> org.eclipse.wst.server.core -> tmp<number> -> wtpwebapps” directory
  2. Copy the ROOT folder from your “apache installation home -> webapps” directory to the directory mentioned in Step 1.  If prompted with overwrite dialog box, select yes and proceed.
  3. Reload http://localhost/ page. Admin start page should now open without any issues!
Advertisements

2 thoughts on “How to resolve admin page opening issue after tomcat configuration in eclipse

  1. In Tomcat 7.0 at least, you have to edit conf/tomcat-users.html and add manager-gui role + some users. Haven’t tried with eclipse though.

    Like

    • yes! You need to include the following (just an example) entry to your tomcat-users.xml file to be able to login as a manger and view the manager-gui page and do tasks such as application deployment.

        <role rolename="manager-gui"/>
        <user username="test" password="test" roles="manager-gui,admin"/>
      

      The above post was mainly to address the issue i faced so many times wherein after starting the tomcat server instance inside my eclipse, i was not able to open the admin page from the browser.

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s